Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1029 (closed defect: fixed)

Opened 11 years ago

Last modified 7 years ago

CatWalk strips leading zeroes from ID URL param of type str

Reported by: nirvana117@… Owned by: anonymous
Priority: normal Milestone: 1.0.x bugfix
Component: Toolbox.Catwalk Version: 0.9a6
Severity: normal Keywords: CatWalk,
Cc:

Description

when i try to change a User info in catwalk, i found catwalk did not update the user info at all.

finally i found catwalk post like this: user_name=DLST&created=None&email_address=None&password=1234561&display_name=12345&objectName=User&id=87201

id=87201 is not correct,it should be id=00087201,because my id type is str and it's value is '00087201'

Change History

comment:1 Changed 11 years ago by jorge.vargas

  • Component changed from Toolbox to Toolbox.Catwalk
  • Milestone changed from 0.9 to 1.0

is this still happening on the 1.0b* releases?

comment:2 Changed 10 years ago by alberto

  • Milestone changed from 1.0 to 1.1

comment:3 Changed 10 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:4 Changed 8 years ago by jorge.vargas

  • Milestone changed from __unclassified__ to 1.x

comment:5 Changed 8 years ago by Chris Arndt

  • Keywords CatWalk, added; CatWalk POST BUG removed
  • Summary changed from CatWalk POST problem with id type is str and id value has leading '0' chars to CatWalk strips leading zeroes from ID URL param of type str
  • Milestone changed from 1.x to 1.0.x bugfix

Probably a wrong string formatting char used in building this URL somewhere in CatWalk. Can somebody confirm, this is still an issue?

comment:6 Changed 7 years ago by chrisz

  • Status changed from new to closed
  • Resolution set to fixed

Yes, this problem still existed. I was able to reproduce it by setting idType = str and creating an entry where the id had a leading zero. Fixed in r6810 for TG 1.0, TG 1.1 and TG 1.5.

Note: See TracTickets for help on using tickets.