Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1064 (closed defect: invalid)

Opened 13 years ago

Last modified 12 years ago

Template Functions in an imported module don't work

Reported by: shahar Owned by: anonymous
Priority: low Milestone:
Component: Kid Version: 0.8
Severity: normal Keywords: template import
Cc:

Description

If I extend the function-defining module it's OK. But if I have several of those and I just want to import the modules - it fails. I did manage to do it with "kid.enable_imports()" before the import statement, but then it is not a Turbogears loaded module so it lacks access to "std" and such.

I still havn't moved from 0.89 to 0.9 - It's shaky enough for me already...

Change History

comment:1 Changed 13 years ago by jorge.vargas

  • Priority changed from normal to low
  • Component changed from TurboGears to Kid

could you post some sample code.

also I suggest you more your almost 2 versions behind with around a 1year old code.

comment:2 Changed 13 years ago by max

  • Status changed from new to closed
  • Resolution set to invalid

I close this ticket because there is no way to reproduce/fix this.

comment:3 Changed 13 years ago by jorge.vargas

shahar I suggest you upgrade to something newer

Note: See TracTickets for help on using tickets.