Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1089 (closed defect: worksforme)

Opened 12 years ago

Last modified 11 years ago

Login seems to cause toolbox to die

Reported by: jbarrett Owned by: anonymous
Priority: high Milestone: 1.5
Component: Toolbox.Catwalk Version: 0.9a6
Severity: normal Keywords:
Cc:

Description (last modified by jorge.vargas) (diff)

Using the quickstart with identity management enabled, when i login something seems to break in the toolbox.

process to replicate:

  1. use quickstart to create a project with identity management
  2. start toolbox
  3. go to catwalk create a user
  4. start the app
  5. go to  http://localhost:8080
  6. login as the user
    • note that login works and the site seems unaffected
  7. refresh the toolbox page

you should get the error message given at the bottom of the ticket.

From a brief examination of the database it appears that a couple of extra tables have been created (tg_visit and tg_visit_identity) however simply deleting them doesn't cause toolbox to start working, only using a tg-admin sql create after deleting. Also note that this doesn't directly effect the site itself, the site is still just as functional as it was, it just prevents you using the toolbox.

If it's important i'm using mysql as a backend. Also i'm using TG 0.9a9 but that isn't an option in your version drop box.


500 Internal error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Page handler: "Unknown column 'child_name' in 'field list'"
Traceback (most recent call last):
  File "c:\python24\lib\site-packages\CherryPy-2.2.1-py2.4.egg\cherrypy\_cphttptools.py", line 103, in _run
    applyFilters('before_main')
  File "c:\python24\lib\site-packages\CherryPy-2.2.1-py2.4.egg\cherrypy\filters\__init__.py", line 151, in applyFilters
    method()
  File "c:\python24\lib\site-packages\TurboGears-0.9a9-py2.4.egg\turbogears\visit\api.py", line 154, in before_main
    plugin.record_request( visit )
  File "c:\python24\lib\site-packages\TurboGears-0.9a9-py2.4.egg\turbogears\identity\visitor.py", line 170, in record_request
    set_current_identity( identity )
  File "c:\python24\lib\site-packages\TurboGears-0.9a9-py2.4.egg\turbogears\identity\__init__.py", line 102, in set_current_identity
    cherrypy.request.user_name = identity.user_name
  File "c:\python24\lib\site-packages\TurboGears-0.9a9-py2.4.egg\turbogears\identity\soprovider.py", line 91, in _get_user_name
    if not self.user:
  File "c:\python24\lib\site-packages\TurboGears-0.9a9-py2.4.egg\turbogears\identity\soprovider.py", line 82, in _get_user
    self._user= user_class.get( visit.user_id )
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\inheritance\__init__.py", line 161, in get
    val = super(InheritableSQLObject, cls).get(id, connection, selectResults)
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\main.py", line 912, in get
    val._init(id, connection, selectResults)
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\main.py", line 955, in _init
    selectResults = self._connection._SO_selectOne(self, dbNames)
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\dbconnection.py", line 576, in _SO_selectOne
    return self.queryOne(
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\dbconnection.py", line 349, in queryOne
    return self._runWithConnection(self._queryOne, s)
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\dbconnection.py", line 220, in _runWithConnection
    val = meth(conn, *args)
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\dbconnection.py", line 342, in _queryOne
    self._executeRetry(conn, c, s)
  File "c:\python24\lib\site-packages\SQLObject-0.7.1dev_r1860-py2.4.egg\sqlobject\mysql\mysqlconnection.py", line 74, in _executeRetry
    return cursor.execute(myquery)
  File "C:\Python24\Lib\site-packages\MySQLdb\cursors.py", line 163, in execute
    self.errorhandler(self, exc, value)
  File "C:\Python24\Lib\site-packages\MySQLdb\connections.py", line 35, in defaulterrorhandler
    raise errorclass, errorvalue
OperationalError: 1054

Powered by CherryPy? 2.2.1

Change History

comment:1 Changed 12 years ago by jorge.vargas

  • Milestone set to 1.0b2

this seems a valid concern, please check it if it was user error close the bug.

comment:2 Changed 12 years ago by jorge.vargas

  • Priority changed from normal to high
  • Component changed from Identity to Toolbox.Catwalk
  • Description modified (diff)

with 1.0b1 I'm getting a big traceback and Catwalk is frozen.

this is certainly an ugly bug

comment:3 Changed 12 years ago by alberto

  • Milestone changed from 1.0b2 to 1.1

comment:4 Changed 12 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:5 Changed 11 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to worksforme
  • Milestone changed from __unclassified__ to 1.1

I cannot reproduce this error using the steps decribed above (I assume that no tg-admin sql create was executed after step 1 and setting dburi?).

My setup:

  • TG 1.0.4.3
  • mysql 5.0.28
  • Python 2.5.1
  • MySQL-python 1.2.2
  • Ubuntu 7.04 i386

I'm using an extra database for the test app with an extra db user that has full privileges (except GRANT) on this database.

I'm closing this ticket now. If somebody still gets this error, please re-open it and report the exact circumstances (i.e. version numbers and whether you followed the steps above exactly).

Note: See TracTickets for help on using tickets.