Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1119 (closed enhancement: fixed)

Opened 13 years ago

Last modified 9 years ago

Add support for python 2.5

Reported by: jorge.vargas Owned by: anonymous
Priority: normal Milestone: 1.0.x bugfix
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

Now that 2.5 is officially out we should start planning

Attachments

py25.patch Download (1.6 KB) - added by fredlin 12 years ago.
patch setup.py for trunk
py25.2.patch Download (2.6 KB) - added by fredlin 12 years ago.
more generic setup.py for 1.0

Change History

comment:2 Changed 13 years ago by tlesher

comment:3 Changed 13 years ago by jorge.vargas

  • Milestone set to __future__

tlesher, thanks I wasn't sure of the official date of the move, in fact I almost posted it on moinmoin.

#507 must be closed too.

comment:4 Changed 12 years ago by jorge.vargas

  • Milestone changed from __future__ to 1.0

I believe we must ship 1.0 with python2.5 support

comment:5 Changed 12 years ago by alberto

  • Milestone changed from 1.0 to 1.1

comment:6 Changed 12 years ago by jorge.vargas

adding to this the only component left is RuleDispatch? which needs to be tested with recent 2.5 pyrex. We should work on this because PJE have said he doesn't has much time to devote to this.

Changed 12 years ago by fredlin

patch setup.py for trunk

Changed 12 years ago by fredlin

more generic setup.py for 1.0

comment:7 Changed 12 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:8 Changed 12 years ago by fredlin

  • Status changed from new to closed
  • Resolution set to fixed

TG >1.0.2 shipped with python 2.5

comment:9 Changed 9 years ago by chrisz

  • Milestone changed from __unclassified__ to 1.0.x bugfix
Note: See TracTickets for help on using tickets.