Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1129 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

require CherryPy >= 2.2.1,<2.9.0 until compatible with CherryPy-3.x

Reported by: jeffk Owned by: anonymous
Priority: normal Milestone:
Component: Installation Version: trunk
Severity: normal Keywords: cherrypy setuptools egg
Cc:

Description

If the trunk is not yet compatible with CherryPy?-3.x, this minor change to setup.py prevents CherryPy?-3 eggs from being installed during # python setup.py develop.

URL: http://www.turbogears.org/svn/turbogears/trunk
Revision: 1930

Index: setup.py
===================================================================
--- setup.py    (revision 1930)
+++ setup.py    (working copy)
@@ -39,7 +39,7 @@
         "TurboCheetah >= 0.9.5",
         "TurboKid >= 0.9.9",
         "Genshi >= 0.3.1",
-        "CherryPy >= 2.2.1",
+        "CherryPy >= 2.2.1,<2.9.0",
         "SQLObject==bugfix,>=0.7.1dev-r1860,<=0.7.99",
         "simplejson >= 1.3",
         "elementtree >= 1.2.6",
...
Processing dependencies for TurboGears==1.1a0
Searching for CherryPy<2.9.0
Reading http://www.turbogears.org/preview/download/index.html
Reading http://peak.telecommunity.com/snapshots
Reading http://www.python.org/pypi/CherryPy/
Reading http://www.cherrypy.org
Reading http://sourceforge.net/project/showfiles.php?group_id=56099
Reading http://www.python.org/pypi/CherryPy/3.0.0beta2
Best match: CherryPy 2.2.1
Downloading http://dl.sourceforge.net/sourceforge/cherrypy/CherryPy-2.2.1.tar.gz
Processing CherryPy-2.2.1.tar.gz
Running CherryPy-2.2.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-CwLUdz/CherryPy-2.2.1/egg-dist-tmp-Ep9611
zip_safe flag not set; analyzing archive contents...
cherrypy.config: module references __file__
cherrypy.lib.profiler: module references __file__
cherrypy.lib.covercp: module references __file__
cherrypy.lib.autoreload: module references __file__
cherrypy.test.test: module references __file__
cherrypy.test.benchmark: module references __file__
cherrypy.test.test_static_filter: module references __file__
cherrypy.test.test_core: module references __file__
cherrypy.test.modpy: module references __file__
cherrypy.test.test_wsgiapp_filter: module references __file__
cherrypy.tutorial.tut10_http_errors: module references __file__
cherrypy.tutorial.tut09_files: module references __file__
Adding CherryPy 2.2.1 to easy-install.pth file
...

Change History

comment:1 Changed 13 years ago by jorge.vargas

  • Status changed from new to closed
  • Resolution set to fixed

it was fix in  http://www.turbogears.org/svn/turbogears/branches/1.0/setup.py but he forgot about trunk

Fixed in r1933

thanks

Note: See TracTickets for help on using tickets.