Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1154 (closed defect: invalid)

Opened 13 years ago

Last modified 9 years ago

SQLObject returning random old data

Reported by: italomaia Owned by: kskuhlman
Priority: high Milestone: 1.0.x bugfix
Component: SQLObject Version: 1.0b1
Severity: critical Keywords: cache
Cc:

Description

After a update, sqlobject sometimes returns old data. Some times it returns the new data as well. Here's a workaround as suggested here:  link

SQLObjectBaseClass._connection.cache.allSubCaches():
cache.clear()

This guy had the same problem:  link

Attachments

1154.tar.gz Download (1.1 KB) - added by jayhem 13 years ago.
test case
tt1154.tar.gz Download (86.9 KB) - added by kskuhlman 11 years ago.
Updated version of example, usable with tg 1.1 & some minor cleanup

Change History

comment:1 Changed 13 years ago by italomaia

  • Owner changed from anonymous to italomaia
  • Status changed from new to assigned

comment:2 Changed 13 years ago by italomaia

  • Status changed from assigned to new
  • Owner italomaia deleted

comment:3 Changed 13 years ago by jorge.vargas

we need to provide a way to reproduce this

a) as a tg bug b) as a sqlobject only test.

comment:4 Changed 13 years ago by jorge.vargas

  • Milestone changed from 1.0b2 to 1.0b3

I'm moving this since we need further prove

Changed 13 years ago by jayhem

test case

comment:5 Changed 13 years ago by jayhem

Please see the thread "old field value reappears" on the turbogears group: " http://groups.google.fr/group/turbogears/browse_thread/thread/318d32bda9ebf47f/9cdf0540a1b91040#9cdf0540a1b91040"

I created a simple testcase, which reproduces the problem for SO+Sqlite. If I switch to SO+MySQL the problem disappears.

Please find attached the necessary files to run the testcase (just drop them in a default TG project called "bug")

Hope this can be fixed soon, as it renders TG completely unusable with the default settings in place. Probably the severity should be "blocker" and priority "highest".

comment:6 Changed 13 years ago by italomaia

  • Priority changed from normal to high

comment:7 Changed 12 years ago by alberto

  • Milestone changed from 1.0b3 to 1.1

comment:8 Changed 12 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:9 Changed 11 years ago by khorn

This ticket has been at "high" priority for over a year...any proof/progres/updates?

comment:10 Changed 11 years ago by kskuhlman

  • Status changed from new to assigned
  • Owner set to kskuhlman

Changed 11 years ago by kskuhlman

Updated version of example, usable with tg 1.1 & some minor cleanup

comment:11 Changed 11 years ago by kskuhlman

  • Status changed from assigned to closed
  • Keywords sqlobject, old data, removed
  • Resolution set to invalid

This was an issue with sqlobject 0.7.0 & sqlite. The fix, in sqlobject's r 1523, was released with so 0.7.1 in Sept. 2006.

I'm attaching an updated version of jayhem's sample project. To see the issue, install so 0.7.0 & start-tt1154.py, then click around for a while. Eventually you'll see stale data. Install 0.7.1 & the problem will go away.

Also closing ticket as invalid, since it was never a TurboGears issue.

comment:12 Changed 9 years ago by chrisz

  • Milestone changed from __unclassified__ to 1.0.x bugfix
Note: See TracTickets for help on using tickets.