Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1175 (closed defect: wontfix)

Opened 12 years ago

Last modified 11 years ago

Logging code throws error in Komodo

Reported by: anseljh Owned by: anonymous
Priority: low Milestone:
Component: unassigned Version: 1.0b1
Severity: normal Keywords: logging komodo windows
Cc:

Description

I'm using the Komodo IDE (specifically Komodo Personal 3.5.1 on Windows XP SP2). When I try to run any TurboGears code from Komodo, I get an ugly error. The offending code appears to be at line 429 of controllers.py in the main turbogears module.

Here's a sample trace:

Traceback (most recent call last):
  File "C:\Program Files\ActiveState Komodo 3.5\lib\support\dbgp\pythonlib\dbgp\client.py", line 1806, in runMain
    self.dbg.runfile(debug_args[0], debug_args)
  File "C:\Program Files\ActiveState Komodo 3.5\lib\support\dbgp\pythonlib\dbgp\client.py", line 1529, in runfile
    h_execfile(file, args, module=main, tracer=self)
  File "C:\Program Files\ActiveState Komodo 3.5\lib\support\dbgp\pythonlib\dbgp\client.py", line 590, in __init__
    execfile(file, globals, locals)
  File "E:\IPLC\iplctg\iplctg\tests\test_model.py", line 7, in __main__
    from turbogears import testutil, database
  File "c:\python24\lib\site-packages\turbogears-1.0b1-py2.4.egg\turbogears\__init__.py", line 6, in turbogears
    from turbogears.controllers import expose, flash, validate, redirect, \
  File "c:\python24\lib\site-packages\turbogears-1.0b1-py2.4.egg\turbogears\controllers.py", line 420, in ?
    class RootController(Controller):
  File "c:\python24\lib\site-packages\turbogears-1.0b1-py2.4.egg\turbogears\controllers.py", line 429, in RootController
    msglogfunc = {0: msglog.info, 1: msglog.warning, 2: msglog.error}
AttributeError: Logger instance has no attribute 'warning'

The same stuff works fine when run from the command line, so I expect it's a Komodo problem, but it's odd nonetheless because Komodo is set up to use my stock Python installation.

??

Change History

comment:1 Changed 12 years ago by jorge.vargas

I don't see how this could be a problem TG can fix.

can you please try

  • take out the autoreload from config
  • post how your IDE calls the external file

comment:2 Changed 12 years ago by jorge.vargas

  • Status changed from new to closed
  • Resolution set to wontfix

without furder input i'm closing....

if someone else finds this please reopen this ticket

comment:3 Changed 12 years ago by anseljh

  • Priority changed from normal to low

I'm not reopening this, but I do have another data point: Komodo 3.5.3 on Mac OS X 10.4.8 and Python 2.4.4 does not throw the same error. Weird!

Note: See TracTickets for help on using tickets.