Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1179 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

[PATCH] utils.py is Python 2.3 incompatible

Reported by: Timur Owned by: anonymous
Priority: normal Milestone:
Component: unassigned Version: 1.0b1
Severity: major Keywords:
Cc:

Description

kw.update(izip(islice(argnames, start, len(argnames) - len(defaults)), args))

does not work because in Python 2.3 update can not take an iterable as argument.

Please see  http://groups.google.com/group/turbogears/browse_frm/thread/218514debdc256d8

Attachments

utils-2.3.diff Download (707 bytes) - added by Timur 13 years ago.
Patch which uses dict.setitem() instead of dict.update()

Change History

Changed 13 years ago by Timur

Patch which uses dict.setitem() instead of dict.update()

comment:1 Changed 13 years ago by Timur

  • Summary changed from utils.py is Python 2.3 incompatible to [PATCH] utils.py is Python 2.3 incompatible

comment:2 Changed 13 years ago by fredlin

  • Status changed from new to closed
  • Resolution set to fixed

merged in [2076], thanks!

Note: See TracTickets for help on using tickets.