Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1186 (closed defect: invalid)

Opened 13 years ago

Last modified 12 years ago

quickstart - prod.cfg not complete -- missing autoreload.package statement

Reported by: dundeemt Owned by: anonymous
Priority: normal Milestone:
Component: tg-admin (non-toolbox) Version: 1.0b1
Severity: major Keywords: prod.cfg quickstart tg-admin
Cc:

Description

when moving to the prod.cfg file tg fails out with an error:

"TurboGears requires autoreload.package to be set. It can be an empty value, which will use CherryPy?'s default behavior which is to check every module. Setting an actual package makes the check much faster."

reproducible: Yes

Steps to reproduce:

  • create a project via tg-admin quickstart
  • move sample-prod.cfg to prod.cfg
  • del/rename dev.cfg
  • attempt to start the project ./start-projectname.py

Failing because the setting: autoreload.package="projectname" is not in the prod.cfg file while it does exist in the dev.cfg

Severity: ?? project won't run until the prod.cfg file is edited to include the autoreload.package statement because it is required by cherrypy -- While not tough to fix I would consider it important since it inhibits from deploying smoothly. There are enough other things to figure out and having to deal with a simple misconfiguration that quickstart should get right -- you get my point.

Change History

comment:1 Changed 13 years ago by dundeemt

The following from line 52 of http://trac.turbogears.org/turbogears/browser/trunk/turbogears/qstemplates/quickstart/dev.cfg_tmpl

autoreload.package="${package}"

needs to be added to line 46 of http://trac.turbogears.org/turbogears/browser/trunk/turbogears/qstemplates/quickstart/sample-prod.cfg_tmpl following

server.environment="production"

comment:2 Changed 13 years ago by dundeemt

  • Status changed from new to closed
  • Resolution set to invalid

My newness with the .cfg files and their use of setup.py as the flag instead of the existence of dev.cfg was part of the problem. The book explicitly says the opposite so it took my a while to drop out of clueless mode and read the code.

sorry.

Note: See TracTickets for help on using tickets.