Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1205 (closed defect: duplicate)

Opened 12 years ago

Last modified 10 years ago

/login redirect fails with SecureResource

Reported by: tic Owned by: Chris Arndt
Priority: normal Milestone: 1.0.x bugfix
Component: Identity Version: 1.0.4b3
Severity: normal Keywords:
Cc: mikael.jansson@…

Description

The setup: A system running FastCGI w/ the dispatcher (changing both request.path and request.object_path for virtual_path_filter.prefix) described in #1199

Standard quickstarted application, with a controller inheriting both from controllers.Controller and identity.SecureResource?, with a requires = identity.not_anonymous(), mounted at, say, foo:

class Foo(controllers.Controller, identity.SecureResource):
    requires = identity.not_anonymous()

    @expose
    def index(self):
        return "Hello, world!"

class Main(controllers.RootController):
    foo = FooController()

Now, go to  http://domain.tld/foo. You won't see the resource and instead be asked to login. When submitting the form, an internal failure occurs. (see attachment:failure-on-redirect.txt Download)

Manual login from  http://domain.tld/login works fine.

Attachments

failure-on-redirect.txt Download (2.1 KB) - added by tic 12 years ago.
controllers.py Download (3.2 KB) - added by tic 12 years ago.

Change History

Changed 12 years ago by tic

comment:1 Changed 12 years ago by tic

  • Cc mikael.jansson@… added

comment:2 Changed 12 years ago by tic

This happens when running as a stand-alone server, too, with virtual_path_filter disabled.

comment:3 Changed 12 years ago by tic

This on trunk r2202.

Changed 12 years ago by tic

comment:4 Changed 12 years ago by jorge.vargas

  • Milestone set to 2.0

your setup is not a common one, and that is probably what is causing the code to fail. this is one of the things we should consider for tg2.0

comment:5 Changed 12 years ago by mramm

  • Milestone changed from 2.0 to 1.1

2.0's Identity replacement isn't likely to have this issue. Perhaps it could be fixed in 1.x somewhere.

comment:6 Changed 11 years ago by Chris Arndt

  • Version changed from trunk to 1.0.4b3
  • Component changed from unassigned to Identity
  • Severity changed from major to normal

comment:7 Changed 11 years ago by faide

  • Milestone changed from 1.1 to 1.1.1

comment:8 Changed 11 years ago by faide

  • Milestone changed from 1.6 to 1.5

comment:9 Changed 10 years ago by Chris Arndt

  • Keywords needs confirmation added
  • Owner changed from anonymous to Chris Arndt
  • Milestone changed from 1.5 to 1.0.x bugfix

comment:10 Changed 10 years ago by kskuhlman

I think that this is a duplicate of #1939, which chrisz fixed in r5145.

comment:11 Changed 10 years ago by kskuhlman

  • Keywords needs confirmation removed
  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.