Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1237 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[PATCH] Test suite not Python 2.3 compatible

Reported by: Felix.Schwarz Owned by: alberto
Priority: high Milestone: 1.0.1
Component: Tests Version: 1.0
Severity: normal Keywords:
Cc:

Attachments

sqlalchemy_no_decorators.patch Download (1.0 KB) - added by Felix.Schwarz 11 years ago.
Patch for test_sqlalchemy.
form_controllers_no_decorators.patch Download (844 bytes) - added by Felix.Schwarz 11 years ago.
Test for test_form_controllers.py

Change History

comment:1 Changed 11 years ago by alberto

  • Owner changed from anonymous to alberto
  • Status changed from new to assigned

A patch would be apprecated :)

Alberto

Changed 11 years ago by Felix.Schwarz

Patch for test_sqlalchemy.

Changed 11 years ago by Felix.Schwarz

Test for test_form_controllers.py

comment:2 Changed 11 years ago by Felix.Schwarz

Alberto: Here are your patches. Please test especially the test_sqlalchemy. I could only verify that there is no "invalid syntax" error because I don't have sqlalchemy installed.

comment:3 Changed 11 years ago by alberto

  • Summary changed from Test suite not Python 2.3 compatible to [PATCH] Test suite not Python 2.3 compatible

comment:4 Changed 11 years ago by alberto

  • Status changed from assigned to closed
  • Resolution set to fixed

Comitted at [2374]. Thanks Felix :)

Alberto

P.S. Next time please provide patches as unified diffs. The easiest way is t run svn diff > my_patch.diff from the root of your svn checkout. Makes thing a hell lot easier :)

Note: See TracTickets for help on using tickets.