Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1244 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

IndentationError when collecting i18n strings from kid temlates.

Reported by: qk Owned by: anonymous
Priority: high Milestone: 1.0.2
Component: Toolbox.admi18n Version: 1.0
Severity: normal Keywords:
Cc:

Description

Should indention be checked during collecting i18n strings from kid templates ?

After looking into traceback there is no posibility to know in which file (line) error is occurc :(

Change History

comment:1 Changed 12 years ago by alberto

  • Milestone changed from 1.0.1 to 1.0.2

comment:2 Changed 12 years ago by faide

  • Status changed from new to closed
  • Resolution set to fixed

The problem is not _if_ the indentation should be checked. Kid templates are compiled to python pyc files so indentation matters (unfortunately should I say?).

And yes it is difficult to find the line in error. But the latest Kid versions make this somewhat easier by providing the line number in error.

comment:3 Changed 12 years ago by chrisz

Just for the records, I found that the poor error reporting here has nothing to do with kid, but with the tokenize module. Luckily, this has also been improved in Python 2.5:

 http://svn.python.org/view/python/trunk/Lib/tokenize.py?rev=51284&r1=43464&r2=51284

Note: See TracTickets for help on using tickets.