Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #129 (closed defect: fixed)

Opened 14 years ago

Last modified 12 years ago

SQLObject classes imported into model.py aren't loaded on tg-admin shell

Reported by: jchu@… Owned by: anonymous
Priority: normal Milestone: 0.9
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

I think it has to do with the import on line 33 of turbogears/command/init.py, but I'm not totally sure.

Attachments

get_model-fix.patch Download (675 bytes) - added by jchu@… 14 years ago.

Change History

comment:1 Changed 14 years ago by kevin

  • Milestone set to 0.9

comment:2 Changed 14 years ago by jchu@…

Ok, I think I'm actually on crack.

The reason my model isn't being imported is because it's in model/init.py not model.py.

I don't know how you want to do the check in get_model, but I think checking for the model.py file isn't enough anymore.

Please accept my patch to check for any type of model module.

Changed 14 years ago by jchu@…

comment:3 Changed 14 years ago by elvelind@…

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 14 years ago by elvelind@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

seems like the patch don't really solve the ticket

comment:5 Changed 14 years ago by elvelind@…

  • Status changed from reopened to closed
  • Resolution set to fixed

When looking closer it does solve it. It was just not applied properly. Fixed now (I hope)

Note: See TracTickets for help on using tickets.