Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #132 (closed defect: duplicate)

Opened 14 years ago

Last modified 12 years ago

Identity code uses threading.local which isn't available in Python 2.3

Reported by: seancazzell@… Owned by: anonymous
Priority: normal Milestone:
Component: Identity Version:
Severity: normal Keywords:
Cc:

Description

The identity code is storing the current logged in user and identity provider in threading.local storage - threading.local is new in Python 2.4. CherryPy? has a backwards compatible thread local storage implementation that we can use if we need it.

But I think we can get rid of these global variables (identity.current / identity.provider):

The logged in user should probably be stored in the cherrypy.request object rather than identity.current. There doesn't appear to be a need for the provider global - an identity provider instance can be created / passed around where it is needed.

Change History

comment:1 Changed 14 years ago by seancazzell@…

I meant to note that this was reported by "pclifford" in the  IRC meeting today. So credit to him for pointing this one out.

comment:2 Changed 14 years ago by seancazzell@…

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone 0.9 deleted

Sorry, this is a dupe - Paul beat me to it!

comment:3 Changed 14 years ago by seancazzell@…

This was a dupe of ticket:131

Note: See TracTickets for help on using tickets.