Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1320 (closed enhancement: duplicate)

Opened 12 years ago

Last modified 9 years ago

[PATCH] @paginate should allow specification of a descending default ordering

Reported by: alastair Owned by: anonymous
Priority: normal Milestone: 1.0.4
Component: TurboGears Version: 1.0
Severity: normal Keywords:
Cc:

Description

Currently, @paginate allows the user to specify the name of the column/attribute on which to order results, but it doesn't let the user specify whether to sort in ascending or descending order.

The attached patch adds a default_order_ascending argument that lets you specify ascending or descending order as required.

Attachments

paginate2.diff Download (1.0 KB) - added by alastair 12 years ago.
Add default_order_ascending argument to @paginate

Change History

Changed 12 years ago by alastair

Add default_order_ascending argument to @paginate

comment:1 Changed 12 years ago by alastair

  • Summary changed from @paginate should allow specification of a descending default ordering to [PATCH] @paginate should allow specification of a descending default ordering

Make it clear that there's a patch attached.

comment:2 Changed 12 years ago by alberto

Could someone please test this and report back?

Alberto

comment:3 Changed 12 years ago by alberto

  • Milestone changed from 1.0.2 to 1.0.3

comment:4 Changed 12 years ago by Chris Arndt

  • Milestone changed from 1.0.3 to 1.0.4

Batch promoting 1.0.3 tickets to Milestone 1.0.4

comment:6 Changed 12 years ago by joelpearson

This ticket is a duplicate of #1354, and the change was committed in r2946. This ticket may be safely closed. (I'd close it myself, but I'm not sure what the protocol is for closing tickets.)

  • Joel

comment:7 Changed 12 years ago by roger.demetrescu

  • Status changed from new to closed
  • Resolution set to duplicate

Joel is right. Today there is already a parameter to specify default order (default_reversed) and also a discussion on ML about improving this feature:

 http://tinyurl.com/ywhdbf

(which, BTW, was started by Joel Pearson) ;)

Anyway, thanks for the great work, alastair !!

Note: See TracTickets for help on using tickets.