Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1324 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

[Errno 13] Permission denied while writing _speedups.pyd

Reported by: shday Owned by:
Priority: normal Milestone: 1.0.2
Component: unassigned Version: 1.0.1
Severity: normal Keywords:
Cc:

Description

This error happened in the middle of night on my dev server. The was no activity on the server at the time. It was probably caused by that fact that my production instance (on the same computer) was using the same file. I guess this is a bug. Here is the trace:

2007-03-11 03:00:44,862 cherrypy.msg INFO ENGINE: SystemExit? raised: shutting do wn autoreloader 2007-03-11 03:00:44,892 cherrypy.msg INFO HTTP: HTTP Server shut down 2007-03-11 03:00:44,892 cherrypy.msg INFO ENGINE: CherryPy? shut down Traceback (most recent call last):

File "C:\Documents and Settings\Daystev\Desktop\trunk\start-srt.py", line 5, i

n ?

from turbogears import update_config, start_server

File "C:\Python24\lib\site-packages\turbogears-1.0.1-py2.4.egg\turbogears\in

it.py", line 6, in ?

from turbogears.controllers import expose, flash, validate, redirect, \

File "C:\Python24\lib\site-packages\turbogears-1.0.1-py2.4.egg\turbogears\cont

rollers.py", line 8, in ?

from dispatch import generic, strategy, functions

File "C:\Python24\lib\site-packages\pil-1.1.6-py2.4-win32.egg\init.py", li

ne 19, in ?

File "build\bdist.win32\egg\dispatch\interfaces.py", line 1, in ? File "C:\Python24\lib\site-packages\pil-1.1.6-py2.4-win32.egg\init.py", li

ne 3, in ?

# $Id: init.py 2134 2004-10-06 08:55:20Z fredrik $

File "build\bdist.win32\egg\protocols\api.py", line 15, in ? File "build\bdist.win32\egg\protocols\adapters.py", line 32, in ? File "build\bdist.win32\egg\protocols\_speedups.py", line 7, in ? File "build\bdist.win32\egg\protocols\_speedups.py", line 4, in bootstrap File "C:\Python24\lib\site-packages\setuptools-0.6c5-py2.4.egg\pkg_resources.p

y", line 799, in resource_filename

return get_provider(package_or_requirement).get_resource_filename(

File "C:\Python24\lib\site-packages\setuptools-0.6c5-py2.4.egg\pkg_resources.p

y", line 1228, in get_resource_filename

self._extract_resource(manager, self._eager_to_zip(name))

File "C:\Python24\lib\site-packages\setuptools-0.6c5-py2.4.egg\pkg_resources.p

y", line 1283, in _extract_resource

manager.extraction_error() # report a user-friendly error

File "C:\Python24\lib\site-packages\setuptools-0.6c5-py2.4.egg\pkg_resources.p

y", line 846, in extraction_error

raise err

pkg_resources.ExtractionError?: Can't extract file(s) to egg cache

The following error occurred while trying to extract file(s) to the Python egg cache:

[Errno 13] Permission denied: 'C:
Documents and Settings
Daystev
Applicatio

n Data
Python-Eggs
pyprotocols-1.0a0dev_r2082-py2.4-win32.egg-tmp
protocols
_speedups.pyd'

The Python egg cache directory is currently set to:

C:\Documents and Settings\Daystev\Application Data\Python-Eggs

Perhaps your account does not have write access to this directory? You can change the cache directory by setting the PYTHON_EGG_CACHE environment variable to point to an accessible directory.

2007-03-11 03:00:49,609 cherrypy.msg INFO ENGINE: SystemExit? raised: shutting do wn autoreloader 2007-03-11 03:00:49,609 cherrypy.msg INFO HTTP: HTTP Server shut down 2007-03-11 03:00:49,619 cherrypy.msg INFO ENGINE: CherryPy? shut down

Change History

comment:1 Changed 12 years ago by shday

I get the same error, except for the first few lines with a timestamp, when I try to restart the dev server (by server I just mean the program). Tonight I'll stop the production server and try again (yes, I'm soon moving the production server to another computer :) ).

comment:2 Changed 12 years ago by shday

I stopped and restarted the production server, now the dev server starts up fine.

comment:3 follow-up: ↓ 4 Changed 12 years ago by faide

Shday did you ever encounter this again ? It seems like a Windows specific problem at the moment of reloading for me.

On win32 you cannot write to a file which is opened by another process. This means that at the time your server tried to reload there was some other process accessing to the pyd file.

Since you said that you had two servers running at the same time this seems logical.

The real "problem" is to know why your server decided to reload in the middle of the night...

comment:4 in reply to: ↑ 3 Changed 12 years ago by shday

I haven't had the problem again. I have no idea why there was a reload in the middle of the night. If the computer crashed or something the server simply wouldn't restart because I have to do that manually.

Replying to faide:

Shday did you ever encounter this again ? It seems like a Windows specific problem at the moment of reloading for me.

On win32 you cannot write to a file which is opened by another process. This means that at the time your server tried to reload there was some other process accessing to the pyd file.

Since you said that you had two servers running at the same time this seems logical.

The real "problem" is to know why your server decided to reload in the middle of the night...

comment:5 Changed 12 years ago by faide

  • Status changed from new to closed
  • Resolution set to fixed

I'll close the bug for the moment then. Please don't hesistate to create a new one or re-open if you encounter this problem again.

Cheers.

Note: See TracTickets for help on using tickets.