Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1334 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

exception_handler() doesn't work when using SQLAlchemy

Reported by: JeroenDekkers Owned by: anonymous
Priority: normal Milestone: 1.0.3
Component: SQLAlchemy Version: 1.0.1
Severity: normal Keywords:
Cc: splee

Description

If you're using SQLAlchemy exception_handler() doesn't work. The problem is easy to reproduce: just quickstart a sqlalchemy project and replace controllers.py with the example from  http://docs.turbogears.org/1.0/ErrorHandling#exceptions-and-rules. It does work with a SQLObject project.

The bug seems to be introduced by r2322, because when I revert the change to errorhandling.py the bug goes away.

Change History

comment:1 Changed 12 years ago by alberto

  • Cc splee added

comment:2 Changed 12 years ago by alberto

  • Milestone changed from 1.0.2 to 1.0.3

comment:4 Changed 12 years ago by paj

  • Component changed from TurboGears to SQLAlchemy

comment:5 Changed 12 years ago by faide

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r3222 (1.0.3dev) and r3223 (1.1dev) thanks for pointing this out...

comment:6 Changed 12 years ago by faide

  • Status changed from closed to reopened
  • Resolution fixed deleted

I reopen it at the moment because even though the issue is fixed for this one it breaks the rollback propagation of r2322...

working on it.

comment:7 Changed 12 years ago by faide

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed correctly without breaking the r2322. Fixes are in r3224 (1.0.3dev) and r3226 (1.1dev) for which I forgot to put a commit comment because I felt asleep on my mouse and it clicked-away before I could do anything :-)

Also added some tests to make the the exceptions handlers are operationnal. At the moment these tests don't validate for SA nor do they test if the rollback is going smoothly but at least they have been added to the test list ...:)

The test for branch 1.0 were committed in r3225.

Note: See TracTickets for help on using tickets.