Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1342 (closed task: wontfix)

Opened 11 years ago

Last modified 9 years ago

Adapt the failing (controller related) tests in trunk to a framework-neutral testing library

Reported by: alberto Owned by: alberto
Priority: highest Milestone: 1.5
Component: unassigned Version: trunk
Severity: critical Keywords:
Cc:

Description

There are a bunch of failing tests in trunk since the merge from the cp3 branch that need porting (read: decoupling from cp2) so they pass.

There's probably nothing broken in the code itself but we cannot tell for sure until this is sorted out.

I'd like to see those tests ported to a framework-neutral testing library so we don't run into this problem again in the future.

What I mean by "framework-neutral" is that we don't poke TG's internals when testing controllers.

This can be achieved by treating the whole test-app as an opaque WSGI app. We emulate requests and we test on the response with no knowledge of how the stack acts behind the scenes.

One library I have some experience with is  Paste fixture and can well serve our purposes I believe. However, any testing library that meets the above requisites would be fine.

I'll assign this to myself but I wont be able to take it until 2-3 weeks. If anyone want to take it before I do go ahead.

This is probably the most important ticket in 1.1 ATM

Alberto

Change History

comment:1 Changed 11 years ago by max

Alberto, I am going to try to implement this starting Apr.2 (may be some work can be done this week).

comment:2 Changed 10 years ago by alberto

  • Keywords sprint added
  • Owner set to alberto

comment:3 Changed 10 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to wontfix

This is probably obsolete since the trunk switched to a Pylons base.

comment:4 Changed 9 years ago by kskuhlman

  • Keywords sprint removed

For posterity, this is a duplicate of #1762, which was implemented in the 1.1 branch.

Note: See TracTickets for help on using tickets.