Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1343 (closed enhancement: fixed)

Opened 10 years ago

Last modified 8 years ago

[PATCH] Allow inversion of identity conditions in decorators

Reported by: ferguscan Owned by: anonymous
Priority: normal Milestone: 1.1.x bugfix
Component: Identity Version: 1.0
Severity: normal Keywords: needs tests
Cc:

Description (last modified by Chris Arndt) (diff)

Created a CompoundPredicate called NotAny, in the same vein as Any and All.

Attachments

none_predicate.diff.gz Download (322 bytes) - added by ferguscan 10 years ago.
none_predicate2.diff Download (850 bytes) - added by faide 9 years ago.
same patch but with proper format

Change History

Changed 10 years ago by ferguscan

comment:1 Changed 10 years ago by ferguscan

Of course it's not called 'None'. It's called 'NotAny?'.

comment:2 Changed 10 years ago by alberto

Please take a look at the  patching guidelines so it's easier to apply. A short unittest would be great... (take a look at turbogears/tests/test_identity.py for ideas).

Thanks! :)

Alberto

comment:3 Changed 10 years ago by alberto

  • Milestone changed from 1.0.2 to 1.0.3

comment:4 Changed 10 years ago by Chris Arndt

  • Milestone changed from 1.0.3 to 1.0.4

Batch promoting 1.0.3 tickets to Milestone 1.0.4

Changed 9 years ago by faide

same patch but with proper format

comment:5 Changed 9 years ago by faide

  • Milestone changed from 1.0.4 to 1.1

This predicate could be interesting, even if I have no use case for it at the moment. I recreated the patch to be in a proper format.

We still need at least one small test case to make sure it works as intended.

comment:6 Changed 9 years ago by faide

  • Description modified (diff)

comment:7 Changed 9 years ago by faide

  • Milestone changed from 1.5 to 1.1

comment:8 Changed 9 years ago by Chris Arndt

  • Keywords needs tests added
  • Description modified (diff)

The new patch does not follow PEP257. This should be corrected before applying this.

comment:9 Changed 9 years ago by faide

  • Milestone changed from 1.1 to 1.1 maintenance

comment:10 Changed 8 years ago by chrisz

  • Status changed from new to closed
  • Resolution set to fixed

Added with unit tests to Tg 1.1 and 1.5 in r6311.

Note: See TracTickets for help on using tickets.