Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1361 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

[PATCH] tg-admin cannot operate on project deployed as an egg

Reported by: chrisz Owned by: anonymous
Priority: normal Milestone: 1.0.2
Component: Deployment Version: trunk
Severity: normal Keywords:
Cc:

Description

After creating a project on my development machine, I was able to run "tg-admin sql create", but when I deployed this project as an egg on a server, this did not work any more. The error message was that I "need to run this from the project folder", even if I ran the command in the egg directory or with the --egg parameter.

It seems this problem appears because the egg-info of the original project is located in the subdirectory ProjectName.egg-info, but in the deployed egg this directory has the name EGG-INFO (i.e. uppercase and without ProjectName). The function get_project_meta in turbogears.util however, only checks for a directory with lowercase name.

I have added a simple patch that solved the problem for me.

Attachments

util.patch Download (1.8 KB) - added by chrisz 10 years ago.
Patch for turbogears.util

Change History

Changed 10 years ago by chrisz

Patch for turbogears.util

comment:1 Changed 10 years ago by alberto

  • Status changed from new to closed
  • Resolution set to fixed

Applied at [2876]. Thanks! :)

Alberto

Note: See TracTickets for help on using tickets.