Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #137 (closed defect: fixed)

Opened 14 years ago

Last modified 12 years ago

Dependency for CherryPy incorrect

Reported by: pythonhead@… Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version:
Severity: blocker Keywords:


In setup.py for TurboGears 0.8a3 the CherryPy? minimum version is incorrect:

install_requires = ["kid >= 0.7adev-r186", "CherryPy? >= 2.1.0-rc2",

It should be CherryPy? >= 2.1.0_rc2

If you use setuptools-0.6a8, tg-admin will fail to find CherryPy? 2.1.0 final or later.

$ tg-admin
Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 5, in ?
    from pkg_resources import load_entry_point
line 2195, in ?
    for dist in working_set.resolve(
line 483, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: CherryPy>=2.1.0-rc2 

See TG mailing list for explanation from PJE:  http://tinyurl.com/a9sse

Change History

comment:1 Changed 14 years ago by pythonhead@…

Actually it should be either '2.1.0rc2' or '2.1.0.rc2' not '2.1.0_rc2' as I said above.

comment:2 Changed 13 years ago by anonymous

  • Status changed from new to closed
  • Resolution set to fixed

Should be moot by now ;)

Note: See TracTickets for help on using tickets.