Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1379 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

tgsetup.py fails TG 1.0.2.2

Reported by: pythonhead Owned by: anonymous
Priority: high Milestone: 1.0.3
Component: TurboGears Version: 1.0.2
Severity: blocker Keywords:
Cc:

Description

I'm trying TG 1.0.2.2 using tgsetup in a clean workingenv(0.6.5) with Python 2.5 in Linux and get this:

<snip>

Searching for PasteScript==1.3.3
Reading http://cheeseshop.python.org/pypi/PasteScript/
Reading http://pythonpaste.org/script/
Reading http://cheeseshop.python.org/pypi/PasteScript/1.3.4
Skipping development or system egg: PasteScript 1.3.3
No local packages or download links found for PasteScript==1.3.3
error: Could not find suitable distribution for Requirement.parse('PasteScript==1.3.3') (--always-copy skips system and development eggs)

Change History

comment:1 Changed 12 years ago by pythonhead

Trying the same thing on another box but with Python 2.4:

Searching for PasteScript==1.1
Reading http://cheeseshop.python.org/pypi/PasteScript/
Reading http://pythonpaste.org/script/
Reading http://cheeseshop.python.org/pypi/PasteScript/1.3.4
Skipping development or system egg: PasteScript 1.1
No local packages or download links found for PasteScript==1.1
error: Could not find suitable distribution for Requirement.parse('PasteScript==1.1') (--always-copy skips system and development eggs)

comment:2 Changed 12 years ago by alberto

Hmm, I'll have to try this on a linux box to see who is "pinning" 1.3.3 (TG itself requires PasteScript >= 0.9.7 so it should fetch 1.3.4 with no problems).

For the mean time, can you try installing 1.3.4 manually before TG to see if the problem persists?

easy_install -U PasteScript==1.3.4

Alberto

comment:3 Changed 12 years ago by alberto

  • Milestone changed from 1.0.2 to 1.0.3

comment:4 Changed 12 years ago by pythonhead

I installed PasteScript manually, then re-ran tgsetup and it complained about PyProtocols?.

I found that the problem is with using workingenv.py. I already had PasteScript and PyProtocols? installed outside of my workingenv, but I had not used the --site-packages' option, so I don't know how tgestup/easy_install was finding anything outside of the workingenv.

After removing PasteScript and PyProtocols? from my true site-packages and using a fresh workingenv, the install went flawlessly.

Note that I already had all the dependencies installed in /usr/lib/python2.5/site-packages, but the only two that gave me problems were PasteScript/PyProtocols?.

Also, when I used easy_install to install PasteScript it complained that my site.py was not generated by setuptools and I had to remove it before being able to use easy_install.

I'll check with Ian Bicking to see if he has any idea what went wrong.

comment:5 Changed 12 years ago by alberto

  • Status changed from new to closed
  • Resolution set to worksforme

This sort of problem has bitten me before... It seems that sometimes workinenvs are not so "clean" if there are setuptools packages installed at system-wide "site-packages". The solution I've found that works-for-me is to never install anything system-wide but keep everything isolated in workingenvs. It might will probably not be appropiate for very scenario though... Maybe workingenv can do something about it so it'll be great if you can forward this issue to Ian.

I'll close this as worksforme since it doesn't seem to be TG specific

Thanks :)

Alberto

comment:6 Changed 12 years ago by guest

We've encountered this same problem elsewhere, and haven't completely figured out a solution. But we (i.e., upstream) are aware of the issue.

Note: See TracTickets for help on using tickets.