Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1420 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Typos in TG2 setup.py

Reported by: nbm Owned by: nbm
Priority: normal Milestone: 2.0
Component: TurboGears Version: trunk
Severity: normal Keywords:
Cc:

Description

There are a few typos in TG2's setup.py - the correct capitalisation for packages and the name for an option.

Attachments

tg-setup.py.typos.patch Download (482 bytes) - added by nbm 12 years ago.

Change History

Changed 12 years ago by nbm

comment:1 Changed 12 years ago by mramm

  • Status changed from new to closed
  • Resolution set to fixed

Fixed by fred. Tommorow there should be a Pylons release, and we can stop depending on pylons trunk.

comment:2 Changed 12 years ago by nbm

  • Status changed from closed to reopened
  • Resolution fixed deleted

It doesn't seem to be committed - was this the ticket you intended to close?

comment:3 Changed 12 years ago by mramm

You're right I should not have closed it.

I won't be commiting the patch exaxtly, since I'll be changing the requirements to reflect Pylon's upcomming released version, rather than the trunk.

But we definitely need to get this fixed.

comment:4 Changed 12 years ago by mramm

Fixed in rev 3255

comment:5 Changed 12 years ago by mramm

Fixed in rev 3255

comment:6 Changed 12 years ago by mramm

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:7 Changed 12 years ago by nbm

  • Status changed from closed to reopened
  • Resolution fixed deleted

Still doesn't look like it is applied in my trunk checkout.

comment:8 Changed 12 years ago by mramm

  • Status changed from reopened to new
  • Owner changed from anonymous to nbm

I just tested this with setup.py develop and all is working properly. Also the genshi and sqlalchemy package names are capitalized properly, and the extras-require is declared properly.

Are you sure you have an up-to date trunk checkout?

comment:9 Changed 12 years ago by nbm

Yes - I have an up-to-date checkout. To verify, I went straight to the source:

svn cat  http://svn.turbogears.org/trunk/setup.py | grep -Ei '(genshi|sqlalchemy|extra)'

'genshi>=0.4', 'sqlalchemy>=0.3',

extras_require={

"extras_require" is fixed, but the Genshi and SQLAlchemy packages are not done properly.

Using easy_install genshi==0.4.3, you can see that the package is not found using lower-case:

Searching for genshi==0.4.3 Reading  http://cheeseshop.python.org/pypi/genshi/ Couldn't retrieve index page for 'genshi' Scanning index of all packages (this may take a while) Reading  http://cheeseshop.python.org/pypi/

Using capitalised:

Searching for Genshi==0.4.3 Reading  http://cheeseshop.python.org/pypi/Genshi/ Reading  http://genshi.edgewall.org/

Same applies to sqlalchemy - it should be SQLAlchemy.

comment:10 Changed 12 years ago by fredlin

  • Status changed from new to closed
  • Resolution set to fixed

fixed in [3271], thanks

Note: See TracTickets for help on using tickets.