Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1422 (closed defect: duplicate)

Opened 12 years ago

Last modified 12 years ago

Default projects log messages twice

Reported by: glezos Owned by: anonymous
Priority: normal Milestone: 1.0.3
Component: TurboGears Version: 1.0.2
Severity: normal Keywords:
Cc:

Description

Default projects and examples on the website are logging DEBUG and INFO messages twice. Setting "server.log_to_screen = False" doesn't seem to do any good.

Change History

comment:1 Changed 12 years ago by mramm

Does this still happen when you turn autoreload off?

comment:2 Changed 12 years ago by glezos

Yes. To replicate problem, create a new project and add these lines in index:

import logging
log = logging.getLogger(__name__)
#same happens with:
#log = logging.getLogger("projname.controllers")
log.info("info")
log.debug("debug")

comment:3 Changed 12 years ago by glezos

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of bug #960.

Any chance of getting this fixed soon?

Note: See TracTickets for help on using tickets.