Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1439 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

can't install turbogears, small path setup.py

Reported by: marc Owned by: anonymous
Priority: normal Milestone: 1.5
Component: TurboGears Version: 1.1 HEAD
Severity: normal Keywords:
Cc:

Description

installation break with error, with patch setup.py it works.

TurboGears Complete Version Information

TurboGears requires:

* TurboGears 1.1b1dev-r3251
* cElementTree 1.0.5-20051216
* configobj 4.3.2
* DecoratorTools 1.4
* RuleDispatch 0.5a0.dev-r2306
* setuptools 0.6c6
* FormEncode 0.7.1
* PasteScript 1.3.5
* elementtree 1.2.6
* simplejson 1.7.1
* CherryPy 2.2.1
* SQLAlchemy 0.3.8
* Genshi 0.4.2
* TurboKid 1.0.1
* TurboCheetah 0.9.5
* TurboJson 1.0
* PyProtocols 1.0a0dev-r2302
* PasteDeploy 1.3.1
* Paste 1.3
* kid 0.9.5
* Cheetah 2.0rc7
* RuleDispatch 0.5a0.dev-r2306
* DecoratorTools 1.4

Toolbox Gadgets 

* info (TurboGears 1.1b1dev-r3251)
* catwalk (TurboGears 1.1b1dev-r3251)
* shell (TurboGears 1.1b1dev-r3251)
* designer (TurboGears 1.1b1dev-r3251)
* widgets (TurboGears 1.1b1dev-r3251)
* admi18n (TurboGears 1.1b1dev-r3251)
* template (TemplateBrowser 1.0Alpha)

Identity Providers 

* sqlobject (TurboGears 1.1b1dev-r3251)
* sqlalchemy (TurboGears 1.1b1dev-r3251)

tg-admin Commands 

* info (TurboGears 1.1b1dev-r3251)
* shell (TurboGears 1.1b1dev-r3251)
* quickstart (TurboGears 1.1b1dev-r3251)
* update (TurboGears 1.1b1dev-r3251)
* sql (TurboGears 1.1b1dev-r3251)
* i18n (TurboGears 1.1b1dev-r3251)
* toolbox (TurboGears 1.1b1dev-r3251)
* setup (TurboSetup 0.2)
* migrate (tgmigrate 0.2)
* data (testdatagears 0.1)
* makexe (tg2exe 0.2)
* migrate (Migration 0.2a4.dev-r642)
* crud (tgcrud 1.0)

Visit Managers 

* sqlobject (TurboGears 1.1b1dev-r3251)
* sqlalchemy (TurboGears 1.1b1dev-r3251)

Template Engines 

* genshi-markup (Genshi 0.4.2)
* genshi-text (Genshi 0.4.2)
* genshi (Genshi 0.4.2)
* kid (TurboKid 1.0.1)
* cheetah (TurboCheetah 0.9.5)
* json (TurboJson 1.0)
* wsautoxml (TGWebServices 1.1.2)
* mako (Mako 0.1.8)
* toscawidgets (ToscaWidgets 0.1a2dev-r3090)
* pylonsmyghty (Pylons 0.9.6dev-r2053)

Widget Packages 

* lightbox (Lightbox 2.0-p1)
* scriptaculous (Scriptaculous 1.6.2)
* submodal (submodal 1.4-2)
* tinymce (TurboTinyMCE 1.0.6)
* mochiinterpreter (MochiInterpreter 1.3.1)
* displayshelf (DisplayShelf 1.0)
* tgfklookup (TGFKLookup 0.1a0.dev-r534)
* checkboxtable (checkboxtable 0.80)
* accordionwidget (AccordionWidget 1.0)
* div_dialogs (DivDialogs 0.1a1.dev-r610)
* multicomplete (MultiComplete 1.0)
* file_fields (FileFields 0.1a6.dev-r612)
* dbryuiwidgets (DBR-YUI-Widgets 0.1-r235)
* selectshuttle (Select-Shuttle 1.2)
* tgopenidlogin (TGOpenIDLogin 0.1)
* tgpaginate (TGPaginate 0.1a0.dev-r663)
* tgcaptcha (TGCaptcha 0.11)
* jquery (jquery 1.1.2)
* TGExtJS (TGExtJS 0.2.2)

TurboGears Extensions 

* visit (TurboGears 1.1b1dev-r3251)
* identity (TurboGears 1.1b1dev-r3251)
* turbomail (TurboMail 2.0.3)
* tgfklookup (TGFKLookup 0.1a0.dev-r534)
* file_server (FileFields 0.1a6.dev-r612)
* tg (twAjaxTools 0.1a0dev-r3048)
* fastdata (TGFastData 0.9a7unofficial)
* toscawidgets (ToscaWidgets 0.1a2dev-r3090)

Attachments

setup.py.diff Download (588 bytes) - added by marc 12 years ago.
patch setup.py

Change History

Changed 12 years ago by marc

patch setup.py

comment:1 Changed 12 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to fixed

Fixed by r3376

comment:2 Changed 11 years ago by Chris Arndt

  • Version changed from 1.1b1 to 1.1 HEAD
Note: See TracTickets for help on using tickets.