Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1442 (closed defect: fixed)

Opened 12 years ago

Last modified 10 years ago

Wiki banner hides text when viewed with IE7

Reported by: faide Owned by: Chris Arndt
Priority: normal Milestone: 1.1.x bugfix
Component: Web site Version:
Severity: major Keywords: wiki tosplit
Cc:

Description (last modified by faide) (diff)

When displaying the wiki with IE7 the TurboGears banner at the top hides the first lines of text. This is not the case when using IE6 or FireFox?.

Attachments

icko_tg.JPG Download (157.3 KB) - added by faide 12 years ago.
A screenshot sent to the ML by "Lisa Ice"

Change History

Changed 12 years ago by faide

A screenshot sent to the ML by "Lisa Ice"

comment:1 Changed 12 years ago by faide

  • Description modified (diff)

comment:2 Changed 12 years ago by Chris Arndt

This is probably caused by something in  http://docs.turbogears.org/wiki/turbogears/css/screen.css. I ran this through  http://jigsaw.w3.org/css-validator/ and fixed a syntax error and commented out some unsupported pseudo-element selectors. Maybe someone with access to a windows machine and IE7 could test this again or play around a little with the CSS and try to fix this?

comment:3 Changed 12 years ago by Chris Arndt

  • Milestone changed from 1.0.3 to 1.0.4

Batch promoting 1.0.3 tickets to Milestone 1.0.4

comment:4 Changed 12 years ago by arski

I couldn't find the code in svn to do a patch, but...

If you replace this code (end of header, start of page div)

</div>

<div id="page" lang="en" dir="ltr">

With this

</div>
<div ></div>
<div id="page" lang="en" dir="ltr">

It works.

comment:5 Changed 12 years ago by Chris Arndt

  • Owner changed from splee to Chris Arndt
  • Milestone changed from 1.0.4 to __unclassified__

comment:6 Changed 12 years ago by Chris Arndt

  • Status changed from new to assigned

Unfortunately the fix suggested by arski, causes IE 6 to put a 170px gap betewwen the header and the main page area.

This needs more investigation.

comment:7 Changed 10 years ago by jorge.vargas

  • Keywords tosplit added
  • Version 1.0.2 deleted
  • Component changed from Web site to Validators

comment:8 Changed 10 years ago by jorge.vargas

  • Component changed from Validators to Web site
  • Milestone __unclassified__ deleted

ups

comment:9 Changed 10 years ago by Chris Arndt

  • Milestone set to 1.1.x bugfix

comment:10 Changed 10 years ago by Chris Arndt

  • Status changed from assigned to closed
  • Resolution set to fixed

Finally (hopefully) fixed this and made text in the wiki look a bit nicer in the process, by not forcing ugly Arial font on users.

Note: See TracTickets for help on using tickets.