Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1447 (closed defect: wontfix)

Opened 10 years ago

Last modified 9 years ago

call_on_startup functions aren't being called in tg-admin shell

Reported by: guest Owned by: anonymous
Priority: normal Milestone: 1.5
Component: TurboGears Version: 1.0.2
Severity: normal Keywords:
Cc: jaraco@…

Description

It appears the call_on_startup callbacks aren't being called when using tg-admin shell. I believe the same behavior is also observed when using service.py ( http://docs.turbogears.org/1.0/WindowsService) or when using tg-admin toolbox, although I haven't confirmed.

I will continue to research the problem.

Change History

comment:1 Changed 10 years ago by guest

  • Cc jaraco@… added

comment:2 Changed 10 years ago by Chris Arndt

  • Milestone changed from 1.0.3 to 1.0.4

Batch promoting 1.0.3 tickets to Milestone 1.0.4

comment:3 Changed 10 years ago by faide

  • Milestone changed from 1.0.4 to 1.1

I don't think schedulers and such should be run when one launches a shell. The call on startup hook is provided so it is possible to start scripts that should run when your server is running.

Your server should not be considered as running when you launch the shell.

The service example is different, but the callback call should (first impression) be handled by the service script... I'll look into this one.

The fixes if any will go in the 1.1 branch.

comment:4 Changed 9 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to wontfix

This ticket has not received feedback for over half a year and - as Florent pointed out and I agree - the issue not valid anyway, since the shell does not start the CherryPy server and therefor the startup scripts should not be run.

As for the windows service issue: if this is still an issue, please provide a proper description in a new ticket. Please note though that the linked documentation page is a contributed page and the attached service.py script is not officially supported. If the original author of the script does not fix the issue then probably nobody will.

Closing ticket as wontfix.

Note: See TracTickets for help on using tickets.