Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1449 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

setup.py broken for python < 2.5

Reported by: cdevienne Owned by: faide
Priority: normal Milestone: 1.5
Component: Installation Version: 1.1 HEAD
Severity: normal Keywords:
Cc:

Description

A syntax error in the sqlobject requirement string makes setup.py fail with the following messages :

error in TurboGears setup command: 'extras_require'
must be a dictionary whose values are strings or lists
of strings containing valid project/version requirement specifiers.

Attachments

setup_py_syntax_fix.patch Download (383 bytes) - added by cdevienne 12 years ago.

Change History

Changed 12 years ago by cdevienne

comment:1 Changed 12 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to fixed

Please make sure that you state against which branch your patch is. The best way to do this is to always create the diff from the root of the repository, otherwise it's hard to know, which of the many "setup.py"s in the repository you mean.

See also  http://docs.turbogears.org/patching_guidelines.

Fixed in r3323. Thanks!

comment:2 Changed 11 years ago by Chris Arndt

  • Version changed from 1.1b1 to 1.1 HEAD
Note: See TracTickets for help on using tickets.