Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1470 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

error with tg-admin quickstart

Reported by: djmwlv Owned by: anonymous
Priority: normal Milestone:
Component: tg-admin (non-toolbox) Version: 1.0.3
Severity: normal Keywords:
Cc:

Description

downloaded latest turbogears (as of 8 aug 07) using tgsetup.py. Created new project and with tg-admin quickstart, answered yes to identity, quickstart gave me the following error:

File "/var/lib/python-support/python2.4/Cheetah/Template.py", line 786, in compile

raise parseError

Cheetah.Parser.ParseError?:

Why is it using cheetah? I thought the default was kid? More importantly, why am I getting this error? Running on Ubuntu 6.10, python 2.4

Attachments

quickstart error stack trace Download (4.9 KB) - added by djmwlv 11 years ago.

Change History

comment:1 Changed 11 years ago by mramm

Cheetah is used for the templates for the python files in the quickstart pages. Since these are plain text python files, and not html/xml kid isn't a very good solution, and anyway we're just using paster to create quickstarted projects, and it is the one requiring cheetah.

comment:2 Changed 11 years ago by mramm

In order to debug this we'll likely need the full stack trace. If you could add it, that would be very helpful.

comment:3 Changed 11 years ago by djmwlv

Hi thanks for the quick response/feedback. Seems it happens with or without Identity. I've tried apt-get-ing all the patches, etc recommended in the wiki. I attach the full stack trace, as requested.

regards

Changed 11 years ago by djmwlv

comment:4 Changed 11 years ago by jn73

Same problem here. Gentoo system with TG 1.0.3.2.

comment:5 Changed 11 years ago by paj

  • Status changed from new to closed
  • Resolution set to fixed

This is now fixed in the 1.0 branch - although I don't know who fixed it.

(I get the problem with 1.0.3.2 but not with 1.0 branch)

Note: See TracTickets for help on using tickets.