Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1490 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

pylons.h deprecated in Pylons 0.96

Reported by: n-org Owned by: anonymous
Priority: high Milestone: 2.0
Component: TurboGears Version: trunk
Severity: normal Keywords: pylons
Cc:

Description

On a plain quickstarted project, I get:

opt/local/lib/python2.5/site-packages/TurboGears2-2.0a1dev_r3399-py2.5.egg/tg/controllers.py:41: DeprecationWarning?: pylons.h is deprecated: use your project's lib.helpers module directly instead. Your lib/helpers.py may require the following additional imports:

from pylons.helpers import log from pylons.i18n import get_lang, set_lang

Use the following in your project's lib/base.py file (and any other module that uses h):

import MYPROJ.lib.helpers as h

(where MYPROJ is the name of your project) instead of:

from pylons import h

pylons.h.error_for=error_for

Change History

comment:1 Changed 11 years ago by mramm

This was fixed at last week's sprint. error_for and value_for don't need to be in helpers anyway...

comment:2 Changed 11 years ago by mramm

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.