Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1504 (closed defect: duplicate)

Opened 12 years ago

Last modified 10 years ago

Pagination doesn't always work with prod.cfg

Reported by: toddm Owned by: Chris Arndt
Priority: normal Milestone: 1.0.x bugfix
Component: TurboGears Version: 1.0.3
Severity: major Keywords: needs confirmation
Cc:

Description

Pagination doesn't always work with prod.cfg. This problem has been verified with 1.0.3.2. See the below thread for details.

 http://groups.google.com/group/turbogears/browse_thread/thread/21314004686ccea0/d5343a087470a206

The hack mentioned in the above thread to use kwargs with functions that don't paginate worked for me, but it is not a good general solution.

Per the thread, "The two attached files show the problem when added to the TurboGears test suite."

Attachments

test_paginate.py Download (2.6 KB) - added by toddm 12 years ago.
test_paginate_template.kid Download (194 bytes) - added by toddm 12 years ago.

Change History

Changed 12 years ago by toddm

Changed 12 years ago by toddm

comment:1 Changed 11 years ago by llucax

  • Severity changed from normal to major

Is there any plan on fixing this? It break all my application in production environments =/

I "upgraded" the bug severity, I hope it's ok with you.

comment:2 Changed 11 years ago by faide

  • Milestone set to 1.6

comment:3 Changed 11 years ago by faide

  • Milestone changed from 1.6 to 1.5

comment:4 Changed 10 years ago by Chris Arndt

  • Owner changed from anonymous to Chris Arndt
  • Keywords needs confirmation added
  • Milestone changed from 1.5 to 1.0.x bugfix

comment:5 Changed 10 years ago by chrisz

  • Status changed from new to closed
  • Resolution set to duplicate

I think this is a duplicate of #1889 and is fixed in TG 1.0.7.

Note: See TracTickets for help on using tickets.