Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1608 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

tg-admin upgrade causes problems with subversion

Reported by: wyuenho Owned by: chrisz
Priority: normal Milestone: 1.0.4
Component: tg-admin (non-toolbox) Version: 1.0.4b2
Severity: normal Keywords:
Cc:

Description

Steps to reproduce:

  1. svnadmin ./repos/tgtest
  2. tg-admin quickstart qstest and then just keep pressing return
  3. cd qstest
  4. svn import -m "initial import" ../tgtest/qstest
  5. cd ..
  6. rm -r qstest
  7. svn co ./repos/tgtest/qstest
  8. cd qstest
  9. tg-admin update -t tgbig
  10. answer y for all questions
  11. svn st
  12. look at the screen with confusion
?      qstest/__init__.pyc
A      qstest/controllers
A      qstest/controllers/__init__.py
A      qstest/controllers/root.py
!      qstest/static/javascript/empty
!      qstest/static/css/empty
!      qstest/controllers.py
M      setup.pyc
M      qstest.egg-info/SOURCES.txt

Expected behavior:
All new files added should be added with "svn add", and all those removed should be done with "svn rm".

Change History

comment:1 Changed 10 years ago by chrisz

  • Owner changed from anonymous to chrisz

I have now checked in some improvements in this regard in r3650.

The controllers module should now be properly deleted in SVN, and these empty files are not created any more.

It is now also possible to create the project in an SVN repository already (i.e. add all the necessary files to that repository) with the --svn` option:

tg-admin quickstart --svn=repos_url project_name

Please let me know whether this solves your problems with tg-admin update.

comment:2 Changed 10 years ago by wyuenho

  • Status changed from new to closed
  • Resolution set to fixed

after trying the reproduction steps (with some slight corrections in the commands :)) again, the ! markers have disappeared as expected in the latest revision. And the --svn option is awesome. Thanks!

comment:3 Changed 10 years ago by wyuenho

  • Status changed from closed to reopened
  • Resolution fixed deleted

actually there's 1 more case that this fix didn't consider is that, if the project already has the controllers.py module removed, durint tg-admin update -t tgbig, the tgbase template is applied first, so controllers.py is svn added to the project, then tgbig is applied, and it attempts to remove controllers.py with svn rm actually results in an error and a ! marker again because the controllers.py hasn't been actually added to the base revision yet.

comment:4 Changed 10 years ago by chrisz

  • Status changed from reopened to closed
  • Resolution set to fixed

Ok, tgbig does now first a svn revert before it tries to svn delete the controllers file. That should solve it.

Note: See TracTickets for help on using tickets.