Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1625 (closed defect: wontfix)

Opened 12 years ago

Last modified 11 years ago

mods.pylonshf.valid validates a get request

Reported by: kwilliams Owned by: alberto
Priority: normal Milestone: 2.0
Component: ToscaWidgets Version:
Severity: normal Keywords:
Cc:

Description

The toscawidgets.mods.pylonshf.valid is being called for both GET and POST requests. According to the toscawidgets.mods.pylonshf.valid doc string:

Given a TW form or dict of validators, valid() will attempt to validate the form or validator dict as long as a POST request is made. No validation is performed on GET requests unless post_only is False.

toscawidgets.mods.pylonshf.validate could be altered such that it only calls toscawidgets.mods.pylonshf.valid on a POST request. This will allow a pylons controller action to be decorated with validate and still be able to display a form as well as handle its data posted from that form.

Attachments

validate_post_only.diff Download (1.2 KB) - added by kwilliams 11 years ago.

Change History

Changed 11 years ago by kwilliams

comment:1 Changed 11 years ago by alberto

  • Status changed from new to closed
  • Resolution set to wontfix

This is by design, the docstring is wrong and has been updated.

Alberto

Note: See TracTickets for help on using tickets.