Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1657 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Write tests for multiple expose decorator functionality

Reported by: mramm Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version: trunk
Severity: normal Keywords:
Cc:

Description

Write tests for:

  • controllers with subcontrollers *lookup function
  • index methods
  • default method
  • positional params for default

There are some samples in the Pylons test suite, but we should have tests in the TG2 core to prevent regressions (esp since there are a few subtle differences between the implementation of two systems)

Change History

comment:1 Changed 12 years ago by mramm

  • Version changed from 1.0.4b3 to trunk
  • Milestone changed from 1.0.4 to 2.0

comment:2 Changed 12 years ago by mramm

  • Summary changed from Write object dispatch unit tests to Write tests for multiple expose decorator functionality

comment:3 Changed 12 years ago by mramm

  • Milestone changed from 2.0 to 2.0-preview

comment:4 Changed 11 years ago by mramm

  • Status changed from new to closed
  • Resolution set to fixed

Lots of controller tests implemented.

comment:5 Changed 11 years ago by anonymous

  • Milestone 2.0-preview-1 deleted

Milestone 2.0-preview-1 deleted

Note: See TracTickets for help on using tickets.