Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1696 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

Better Debugging output for Genshi Template errors

Reported by: percious Owned by: anonymous
Priority: high Milestone:
Component: TurboGears Version: trunk
Severity: normal Keywords:
Cc:

Description

Whenever I create a Genshi Error I get a traceback that looks like this:

Exception happened during processing of request from ('127.0.0.1', 51634)
Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/httpserver.py", line 1053, in process_request_in_thread
    self.finish_request(request, client_address)
  File "/usr/local/lib/python2.5/SocketServer.py", line 254, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/local/lib/python2.5/SocketServer.py", line 522, in __init__
    self.handle()
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/httpserver.py", line 432, in handle
    BaseHTTPRequestHandler.handle(self)
  File "/usr/local/lib/python2.5/BaseHTTPServer.py", line 316, in handle
    self.handle_one_request()
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/httpserver.py", line 427, in handle_one_request
    self.wsgi_execute()
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/httpserver.py", line 287, in wsgi_execute
    self.wsgi_start_response)
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/cascade.py", line 121, in __call__
    return self.apps[-1](environ, start_response)
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/registry.py", line 334, in __call__
    app_iter = self.application(environ, start_response)
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/recursive.py", line 80, in __call__
    return self.application(environ, start_response)
  File "/usr/local/lib/python2.5/site-packages/Paste-1.6-py2.5.egg/paste/errordocument.py", line 185, in __call__
    app_iter = self.application(environ, change_response)
  File "/usr/local/lib/python2.5/site-packages/WebError-0.8dev_20071119-py2.5.egg/weberror/evalexception/middleware.py", line 220, in __call__
    return self.respond(environ, start_response)
  File "/usr/local/lib/python2.5/site-packages/WebError-0.8dev_20071119-py2.5.egg/weberror/evalexception/middleware.py", line 370, in respond
    exc_data = collector.collect_exception(*exc_info)
  File "/usr/local/lib/python2.5/site-packages/WebError-0.8dev_20071119-py2.5.egg/weberror/exceptions/collector.py", line 509, in collect_exception
    return col.collectException(t, v, tb, limit=limit)
  File "/usr/local/lib/python2.5/site-packages/WebError-0.8dev_20071119-py2.5.egg/weberror/exceptions/collector.py", line 344, in collectException
    data = self.collectLine(tb, extra_data)
  File "/usr/local/lib/python2.5/site-packages/WebError-0.8dev_20071119-py2.5.egg/weberror/exceptions/collector.py", line 281, in collectLine
    if locals.has_key('__traceback_supplement__'):
AttributeError: 'Context' object has no attribute 'has_key'

Which does not explain the actual error. I think this related to the weberror ticket which may be fixed in pylons, but this functionality should be checked before release.

Change History

comment:1 Changed 11 years ago by mramm

  • Priority changed from normal to high

I got this same error when I returned a 'data' key n my controller dictionary -- regardless of the template. Not sure this ticket has a meaningful title, and not sure what's happening based on the traceback.

comment:2 Changed 11 years ago by mramm

Actually, this looks like a WebError? issue, if we can reproduce it with the latest version of WebError?, we can probaby get the WebError? folks to help us out with it.

comment:3 Changed 11 years ago by brickenstein

I have reproduced the issue with the current source of today (fetched it via Mercurial).

comment:4 Changed 11 years ago by mramm

Has anybody posted this bug to the WebError? project bug tracker?

comment:5 follow-up: ↓ 6 Changed 11 years ago by brickenstein

I update Pylons, WebError?, etc. regularly and now I didn't get the error any more for a long time. Maybe something changed during the last two weeks.

comment:6 in reply to: ↑ 5 Changed 11 years ago by BillZ

  • Status changed from new to closed
  • Resolution set to fixed

Replying to brickenstein:

I update Pylons, WebError?, etc. regularly and now I didn't get the error any more for a long time. Maybe something changed during the last two weeks.

Tested the bug at the PyCon? sprint and it appears to be working. Recommend closing the ticket.

comment:7 Changed 10 years ago by anonymous

  • Milestone 2.0-preview-1 deleted

Milestone 2.0-preview-1 deleted

Note: See TracTickets for help on using tickets.