Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1717 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

[PATCH] Cannot separate savisit into its own database

Reported by: toshio Owned by: anonymous
Priority: normal Milestone: 1.1
Component: TurboGears Version: 1.0.4.2
Severity: normal Keywords:
Cc:

Description

According to #1238 having visit in a separate database from the application database is supposed to work under SQLAlchemy. This is not yet correct. The problem is that the get_engine() call only returns the database configured in the application's configuration file while the table could actually be created in a different database (as documented at  http://docs.turbogears.org/1.0/SQLAlchemy). I needed to apply the attached patch to get this to work.

Attachments

turbogears-separate-visit-db.patch Download (973 bytes) - added by toshio 9 years ago.
savisit.py that works with 0.4.x and 0.3.9+

Change History

comment:1 Changed 9 years ago by jek

I'd suggest s/.get_engine()/.bind/ in that patch (0.3.9+)

Changed 9 years ago by toshio

savisit.py that works with 0.4.x and 0.3.9+

comment:2 Changed 9 years ago by toshio

Done. Tested against SA-0.4.2p3.

comment:3 Changed 9 years ago by faide

  • Milestone changed from 1.5 to 1.1

comment:4 Changed 9 years ago by faide

  • Status changed from new to closed
  • Resolution set to fixed

Applied in r5456, thanks toshio.

Note: See TracTickets for help on using tickets.