Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1720 (closed defect: wontfix)

Opened 11 years ago

Last modified 11 years ago

tgsetup.py doesn't install SQLObject/SQLAlchemy

Reported by: salty-horse Owned by: anonymous
Priority: normal Milestone: 1.5
Component: TurboGears Version: 1.0.4.3
Severity: normal Keywords:
Cc:

Description

Using  http://turbogears.org/download/tgsetup.py version 1.0.4.3

When executing tgsetup.py, it installs TurboGears and various required packages, but doesn't install an ORM like SQLObject or SQLAlchemy. It then causes warnings like "SQLObject is missing, toolbox designer won't work" when running "tg-admin quickstart"

SQLObject should be installed automatically.

Change History

comment:1 Changed 11 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to wontfix

Works as designed. Since TurboGears version 1.0.4b3 installation of an ORM is not required. (See the ChangeLog. Instead, the ORM will be installed when you install an application that requires it (for example, when identity is used).

The reason is that TurboGears can be used without any ORM and there are sites that don't even need database access. If you want, you can also use a Python DB-API layer or any other database system directly.

Solution: follow the instructions given in the error message, i.e.:

easy_install SQLObject

or

easy_install SQLAlchemy
Note: See TracTickets for help on using tickets.