Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1722 (closed defect: invalid)

Opened 11 years ago

Last modified 10 years ago

admi18n javascript is broken

Reported by: cvogler Owned by: anonymous
Priority: normal Milestone: 1.1b2
Component: TurboGears Version: 1.0.4.3
Severity: major Keywords: i18n, kid, javascript, needs feedback
Cc:

Description

The Javascript on the admi18n pages (language_management in particular) is broken. Clicking on "Compile selected locales/Merge strings" has no effect; neither does clicking on any of the message id/message string boxes on the translation page, for this matter.

I tracked down the problem to Javascript syntax errors in the for loops of the type:

for(var i=0;i < elements.length;i++)

This looks like the old problem of Kid escaping "<" inside CDATA elements. So, it seems that the easiest way to fix this would be to move the Javascript code out of the template and into an external file.

What I don't understand, though, is how this could ever have worked. It did when I used TurboGears 1.0.1.

Change History

comment:1 Changed 11 years ago by faide

  • Priority changed from normal to high

comment:2 Changed 10 years ago by faide

  • Milestone changed from 1.5 to 1.1

comment:3 Changed 10 years ago by Chris Arndt

  • Milestone changed from 1.1 to 1.1 beta 1

comment:4 Changed 10 years ago by Chris Arndt

  • Priority changed from high to normal
  • Keywords i18n, kid, javascript, needs feedback added; i18n kid javascript removed

I can not reproduce this with the current (r5308) HEAD of the 1.0 or 1.1 branch. Can somebody confirm that this is still an issue? If not, I'll close this bug as invalid before the "1.1 beta" release.

comment:5 Changed 10 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to invalid

Beta 1 is out. Nobody reported this as still broken. If you can reproduce this, please re-open ticket

Note: See TracTickets for help on using tickets.