Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1782 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[Patch] AutoCompleteField broken with Mochikit 1.3.1

Reported by: Felix.Schwarz Owned by: Felix.Schwarz
Priority: normal Milestone: 1.0.x bugfix
Component: TurboGears Version: 1.0.4.4
Severity: normal Keywords:
Cc: lmacken

Description

When using the AutoCompleteField and AutoCompleteTextField widgets, the spinner keeps spinning even after the results are received. No autocompletion suggestions appear either. I do see (using Firebug) that the TG app does return some json data (looks good) so it appears to be some callback problem.

The problem can be reproduced even when using the TG Toolbox in a quickstarted TG project.

Others experience this, too:  https://www.redhat.com/archives/fedora-devel-list/2008-March/msg01967.html

Attachments

spinner_1782.patch Download (658 bytes) - added by Felix.Schwarz 11 years ago.
This patch fixes the problem for me (Mochikit 1.3 AND 1.4)

Change History

comment:1 Changed 11 years ago by Felix.Schwarz

  • Owner changed from anonymous to Felix.Schwarz
  • Status changed from new to assigned

I found that the problem was introduced in [4225] while attempting to make the javascript code compatible with MochiKit? 1.4. Unfortunately the condition which decides if getStyle should be defined is wrong (at least on Firefox 2/Linux), typeof('getStyle') always returns 'string' on my computer (with MochiKit? 1.3.1 and MochiKit? 1.4).

Changed 11 years ago by Felix.Schwarz

This patch fixes the problem for me (Mochikit 1.3 AND 1.4)

comment:2 Changed 11 years ago by Felix.Schwarz

  • Summary changed from spinner keeps spinning in AutoCompleteField and AutoCompleteTextField to [Patch] spinner keeps spinning in AutoCompleteField and AutoCompleteTextField

comment:3 Changed 11 years ago by Felix.Schwarz

  • Summary changed from [Patch] spinner keeps spinning in AutoCompleteField and AutoCompleteTextField to [Patch] AutoCompleteField broken with Mochikit 1.3.1

comment:4 Changed 11 years ago by chrisz

  • Status changed from assigned to closed
  • Resolution set to fixed

Thanks, fixed in r4386.

Note: See TracTickets for help on using tickets.