Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1823 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

allow non-ascii urls

Reported by: matiu Owned by: chrisz
Priority: high Milestone: 1.5
Component: TurboGears Version: 1.1 HEAD
Severity: major Keywords:
Cc:

Description

My DB has a unique name field which is unicode. My Genshi templates render that as utf-8. When people click on the url, tg throws a wobbly trying to log the thing. Example url is: /M%C3%9CTEK%20Chargeview

This patch fixes that.

Attachments

unicodeLogging.patch Download (1015 bytes) - added by matiu 11 years ago.

Change History

Changed 11 years ago by matiu

comment:1 Changed 11 years ago by matiu

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1763. Just need someone to apply the patch please :D

Note: See TracTickets for help on using tickets.