Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1848 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

tw.forms dependency breaks tgdev installation

Reported by: chrismiles Owned by: alberto
Priority: highest Milestone: 2.0
Component: ToscaWidgets Version: trunk
Severity: normal Keywords:
Cc:

Description

Installation of tgdev dependencies fail when trying to install ToscaWidgets?>=0.8.7dev-20080530. The error from "python setup.py develop" is:

Searching for ToscaWidgets>=0.8.7dev-20080530
Reading http://pypi.python.org/simple/ToscaWidgets/
Reading http://toscawidgets.org/
No local packages or download links found for ToscaWidgets>=0.8.7dev-20080530
error: Could not find suitable distribution for Requirement.parse('ToscaWidgets>=0.8.7dev-20080530')

This is caused by tw.forms requesting ToscaWidgets?>=0.8.7dev which has not been released.

This can be temporarily fixed by editing the tw.forms requirements, to request ToscaWidgets >= 0.8.6 instead. Example:

$ sudo vim /usr/lib/python2.5/site-packages/tw.forms-0.8.1.2-py2.5.egg/EGG-INFO/requires.txt

then re-run "python setup.py develop" for tgdev.

Also see  http://groups.google.com/group/turbogears-trunk/browse_frm/thread/d82c44ec95db8ad9

Change History

comment:1 Changed 11 years ago by chrismiles

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed now that ToscaWidgets? 0.8.7 has been released.

Note: See TracTickets for help on using tickets.