Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1900 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

When using SQLAlchemy, the db_uri is managed by SQLObject

Reported by: Gustavo Owned by: anonymous
Priority: high Milestone:
Component: TurboGears Version: 1.0.5
Severity: critical Keywords:
Cc:

Description

By default, in the unittests for the model, the db_uri is set as:

database.set_db_uri("sqlite:///:memory:")

But if I'm using SQLAlchemy instead of SQLObject, I'll have problems unless I replace the line above by:

database.set_db_uri("sqlite:///:memory:", package="sqlalchemy")

Please correct this line for SQLAlchemy-powered projects.

Change History

comment:1 Changed 11 years ago by Gustavo

  • Version changed from 1.0.4.4 to 1.0.5

comment:2 Changed 11 years ago by Gustavo

  • Summary changed from When using SQLAlchemy, the db_uri is managed by SQLAlchemy to When using SQLAlchemy, the db_uri is managed by SQLObject

typo fix in the title

comment:3 Changed 11 years ago by splee

  • Status changed from new to closed
  • Resolution set to invalid

This is intended behaviour. The default for Turbogears 1.0.x is still SQLObject. database.set_db_uri has no way of knowing that you've set your project up using SQLAlchemy so it assumes you're using the default ORM (i.e. SQLObject) if you just pass in a URI.

You must pass the package parameter if you're using SQLAlchemy or any other ORM.

Note: See TracTickets for help on using tickets.