Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #1969 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Identity-enabled quickstarted apps fail unit tests using SQLAlchemy

Reported by: kskuhlman Owned by: kskuhlman
Priority: high Milestone: 1.1b1
Component: TurboGears Version: 1.1 HEAD
Severity: normal Keywords: needs re-test
Cc:

Description

When testing a 1.1 or 1.5 identity-enabled quickstarted SQLAlchemy app, you get an error "Class '<class 'turbogears.visit.savisit.TG_Visit'>' already has a primary mapper defined".

Identity-enabled quickstarted apps using SQLObject pass tests.

Change History

comment:1 Changed 11 years ago by Chris Arndt

  • Milestone changed from 1.1 to 1.1 beta 1

comment:2 Changed 11 years ago by droggisch

  • Owner changed from anonymous to Chris Arndt

I tried this, with r5294, and can't reproduce it.

comment:3 Changed 11 years ago by Chris Arndt

  • Owner changed from Chris Arndt to kskuhlman

Why do you assign it to me then?

comment:4 Changed 11 years ago by Chris Arndt

I can not reproduce this with the current (r5308) 1.1 branch HEAD. I even uncommented the model test in <project>/<pkg>/tests/test_model.py and fixed the model import and the test ran fine.

I also tried this with the current 1.5 branch HEAD, and I don't get the error reported here but I get lots of other errors as I progressively fixed errors in the test code that is produced by the current quickstart templates in 1.5. They are outdated and don't work with the latest changes in turbogears.testutil. Also testutil in 1.5 does not have the latest changes implemented in the 1.1 branch (e.g. renaming of TGWebTest to TGTest). I'll have opened a seperate ticket for the 1.5 milestone for this (#1972).

Ken, can you please re-test and close this ticket if appropriate?

comment:5 Changed 11 years ago by Chris Arndt

  • Keywords needs re-test added

comment:6 Changed 11 years ago by faide

Also tested in r5342 1.1 branch HEAD and it works with no problem with an SQLAlchemy based identity enabled application.

comment:7 Changed 11 years ago by faide

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.