Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2001 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[PATCH] Buffet default renderer is not configured

Reported by: TimurIzhbulatov Owned by: faide
Priority: low Milestone: 2.0b1
Component: TurboGears Version: trunk
Severity: normal Keywords: buffet renderer genshi i18n xhtml doctype
Cc:

Description

The attached patch aims to fix the following regression issues in TG2:

  • i18n in Genshi templates doesn't work
  • default Genshi output format doesn't match the doctype in templates

The fix should work for most users at least as long as they don't change default renderer. Probably, there should be a more 'correct' way of defining default options rather than just hard coding them (adding an instance variable which will be updated in project's app_cfg.py, getting options from pylons.config, whatever), but I think this should be fine for now because Buffet will be deprecated in 2.0.

Attachments

buffet-genshi-fix.diff Download (1.0 KB) - added by TimurIzhbulatov 11 years ago.

Change History

Changed 11 years ago by TimurIzhbulatov

comment:1 Changed 11 years ago by TimurIzhbulatov

  • Milestone changed from 1.9.7a5 to 2.0

comment:2 Changed 11 years ago by TimurIzhbulatov

  • Milestone changed from 2.0 to 2.0b1

comment:3 Changed 11 years ago by mramm

  • Priority changed from normal to low

The goal with 2.0b1 is to make the new render functions work perfectly, but we should apply this so that people using use_legacy_renderer = True set can still use internationalization with the deprecated but still supported buffet renderer.

comment:4 Changed 11 years ago by mramm

  • Status changed from new to closed
  • Resolution set to fixed

patch applied in r5874

Note: See TracTickets for help on using tickets.