Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2009 (closed defect: invalid)

Opened 11 years ago

Last modified 10 years ago

Catwalk connection polling

Reported by: paigeadele Owned by: anonymous
Priority: normal Milestone: 1.1.x bugfix
Component: Toolbox Version: 1.0.7
Severity: normal Keywords: needs feedback
Cc:

Description

Hello,

I had some trouble with mod_proxy and catalk today. As you are probably fully aware of catwalk has a feature (-c or --add-host) for specifying additional hosts that are allowed to connect to catwalk and interact with it. Upon connecting to catwalk through mod_proxy in apache it said please allow with -c ::FFFF:127.0.0.1 which didn't work-- also shows in the catwalk log that I'm connecting from there. I finally guessed this and used -c <the ip that I'm connecting from> and it worked! So it looks like catwalk's host block feature is using two different means of connection polling to determine where I am connecting from.

Change History

comment:1 Changed 11 years ago by Chris Arndt

  • Keywords needs feedback added
  • Priority changed from high to normal
  • Severity changed from critical to normal

I'm not sure I completely understand you problem and how you solved it.

Can you please provide the exact commands you used to start teh Toolbox/Catwalk? and also the exact error messages you got it?

comment:2 Changed 11 years ago by paigeadele

OK, so this is what you do:

setup a vhost in apache that uses mod proxy on a server different from the box you're going to be working from like this:

<VirtualHost? *:80>

#DocumentRoot? /home/erratic/public_html/ #<Directory "/home/erratic/public_html/"> # Options Indexes FollowSymLinks? # AllowOverride? All # Order allow,deny # Allow from all #</Directory> #ErrorLog? logs/evilx.devel.ws.error.log #CustomLog? logs/evilx.devel.ws.custom.log combined ServerName? catwalk.devel.ws UseCanonicalName? Off ServerSignature? Off ProxyPass? /  http://127.0.0.1:7654/ ProxyPassReverse? /  http://127.0.0.1:7654/ ProxyPreserveHost? On ProxyRequests? Off ProxyPass? /error/ ! ProxyPass? /icons/ ! ProxyPass? /favicon.ico ! #ProxyPass? /static/ ! AddDefaultCharset? utf-8

</VirtualHost?>

Now, start the catwalk server and make sure it runs on port 7654 (The default for the installation I had) Now open up your web browser and point it to your equivalent of "catwalk.devel.ws" which keep in mind you're not running the web browser on the same machine as the server thats running catwalk and mod_proxy. It will give you this message:

No access for ::ffff:127.0.0.1

By default only localhost (127.0.0.1) has access to the Toolbox

You can provide access to your client by passing your host address to Toolbox as a parameter. Ex:

tg-admin toolbox -c ::ffff:127.0.0.1

However when you do this it still gives you the same message: unless you specify for example in my case -c 75.165.82.108 Which is what it should suggest, but doesn't because it's polling connections in a different way than it's evaluating them or else specifying -c 75.165.82.108 wouldn't work--which it does. Please get back to me if this doesn't explain it, though I can't really think of a better way to explain it...

comment:3 Changed 11 years ago by Chris Arndt

  • So is 75.165.82.108 the IP address of the server where Apache/TG are running or the IP address of your client in your example?
  • Have you tried this with TurboGears 1.1? The IP parsing code changed considerably there.
  • You shouldn't run the Toolbox standalone in a production environment. It is meant as a development tool only. Mount the CatWalk Controller in your application instead. See  http://docs.turbogears.org/1.0/Catwalk for more information.

comment:4 Changed 11 years ago by faide

  • Milestone changed from 1.1 to 1.1 maintenance

comment:5 Changed 10 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to invalid

No feeedback in almost a year and not enough information to reproduce this. Closing this ticket as invalid.

Note: See TracTickets for help on using tickets.