Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2018 (closed enhancement: fixed)

Opened 9 years ago

Last modified 8 years ago

Add a config setting for using TG 1.0 with MochiKit 1.4

Reported by: chrisz Owned by: faide
Priority: normal Milestone: 1.0.x bugfix
Component: TurboGears Version: 1.0.7
Severity: normal Keywords:
Cc:

Description

In TG 1.1 and above, you can choose the MochiKit? version via TGMochiKit. Now that MochiKit? 1.4 has been released, it should be made available and included in TG 1.0 as well. I suggest not to add TGMochiKit in TG 1.0, since this would add another dependency and might break compatibility. Instead, I suggest to just include both MK 1.3 and MK 1.4, add a setting for choosing the version, and let the default be MK 1.3 since we don't want to break backward compatibility for TG 1.0 any more.

Change History

comment:1 Changed 9 years ago by faide

granted if it does not break a single thing in 1.0 :)

comment:2 Changed 8 years ago by chrisz

  • Status changed from new to closed
  • Resolution set to fixed

MochiKit 1.4.2 is now added in r5849. You need to set tg.mochikit_version or tg_mochikit.version to 1.4.2 to make use of it. For backward compatibility, MochiKit 1.3.1 will still be used in TG 1.0 if this is not explicitly set, so nothing will break (hopefully :).

Note: See TracTickets for help on using tickets.