Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2028 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

Install fails with incompatable dependency on decorator

Reported by: a+tg2@… Owned by: faide
Priority: normal Milestone: 2.0b1
Component: TurboGears Version: 1.0.7
Severity: major Keywords: decorator 2.2.0 nose easy_install
Cc:

Description

Nose depends on decorator>=2.2.0. Something else installs decorator 2.0.1. So easy_install -i  http://www.turbogears.org/2.0/downloads/current/index tg.devtools fails with an inconsistent dependency error while trying to install nose.

Do it in a new, empty virtualenv & you'll see the problem (found on Windows; should be universal).

Change History

comment:1 Changed 11 years ago by mramm

  • Status changed from new to closed
  • Resolution set to worksforme
  • Milestone changed from 1.9.7b1 to 2.0b1

I cannot reproduce this, so I assume that it's fixed in the latest index.

Note: See TracTickets for help on using tickets.