Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2035 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

setup.py runs under IDLE but command line 'python setup.py' dies

Reported by: GeorgeFLeCompte Owned by: faide
Priority: normal Milestone: 1.1
Component: TurboGears Version: 1.0.7
Severity: normal Keywords:
Cc:

Description

The following file runs under IDLE but using a command line I get an error: from setuptools import setup, find_packages ImportError?: no module named setuptools.


# -*- coding: utf-8 -*-

from setuptools import setup, find_packages
from turbogears.finddata import find_package_data

import os
execfile(os.path.join("petinfostore", "release.py"))

packages=find_packages()
package_data = find_package_data(where='petinfostore',
    package='petinfostore')
if os.path.isdir('locales'):
    packages.append('locales')
    package_data.update(find_package_data(where='locales',
        exclude=('*.po',), only_in_packages=False))

setup(
    name="PetInfoStore",
    version=version,
    # uncomment the following lines if you fill them out in release.py
    #description=description,
    #author=author,
    #author_email=email,
    #url=url,
    #download_url=download_url,
    #license=license,

    install_requires=[
        "TurboGears >= 1.0.7",
        "SQLObject>=0.10.1"
    ],
    zip_safe=False,
    packages=packages,
    package_data=package_data,
    keywords=[
        # Use keywords if you'll be adding your package to the
        # Python Cheeseshop

        # if this has widgets, uncomment the next line
        # 'turbogears.widgets',

        # if this has a tg-admin command, uncomment the next line
        # 'turbogears.command',

        # if this has identity providers, uncomment the next line
        # 'turbogears.identity.provider',

        # If this is a template plugin, uncomment the next line
        # 'python.templating.engines',

        # If this is a full application, uncomment the next line
        # 'turbogears.app',
    ],
    classifiers=[
        'Development Status :: 3 - Alpha',
        'Operating System :: OS Independent',
        'Programming Language :: Python',
        'Topic :: Software Development :: Libraries :: Python Modules',
        'Framework :: TurboGears',
        # if this is an application that you'll distribute through
        # the Cheeseshop, uncomment the next line
        # 'Framework :: TurboGears :: Applications',

        # if this is a package that includes widgets that you'll distribute
        # through the Cheeseshop, uncomment the next line
        # 'Framework :: TurboGears :: Widgets',
    ],
    test_suite='nose.collector',
    entry_points = {
        'console_scripts': [
            'start-petinfostore = petinfostore.commands:start',
        ],
    },
    # Uncomment next line and create a default.cfg file in your project dir
    # if you want to package a default configuration in your egg.
    #data_files = [('config', ['default.cfg'])],
    )


Attachments

setup.py Download (2.4 KB) - added by GeorgeFLeCompte 11 years ago.
Created by tg-admin quickstart PetInfoStore?

Change History

Changed 11 years ago by GeorgeFLeCompte

Created by tg-admin quickstart PetInfoStore?

comment:1 Changed 11 years ago by faide

  • Status changed from new to closed
  • Resolution set to invalid

I could not reproduce your bug with tg 1.1 nor tg 1.0.7... closing as invalid. If you still encounter a problem like this one don't hesitate to ping us directly in the mailing list so we can investigate with you.

Note: See TracTickets for help on using tickets.