Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #210 (closed defect: fixed)

Opened 12 years ago

Last modified 10 years ago

[307] Nose version requirement change breaks install.

Reported by: steve.tindle@… Owned by: anonymous
Priority: normal Milestone:
Component: Installation Version:
Severity: major Keywords:
Cc:

Description

When trying to do a python setup.py develop, setup tools tries to process dependencies for nose. Output:

leonexis@weathertop:~/workspace/turbogears$ sudo python setup.py develop
running develop
running egg_info
writing requirements to ./TurboGears.egg-info/requires.txt
writing ./TurboGears.egg-info/PKG-INFO
writing top-level names to ./TurboGears.egg-info/top_level.txt
writing entry points to ./TurboGears.egg-info/entry_points.txt
running build_ext
Creating /usr/lib/python2.4/site-packages/TurboGears.egg-link (link to .)
TurboGears 0.9a0dev-r308 is already the active version in easy-install.pth
Installing tg-admin script to /usr/bin

Installed /home/leonexis/workspace/turbogears
Processing dependencies for TurboGears==0.9a0dev-r308
Searching for nose<0.8
Reading http://www.python.org/pypi/nose/
Reading http://somethingaboutorange.com/mrl/projects/nose/
No local packages or download links found for nose<0.8
error: Could not find distribution for Requirement.parse('nose<0.8')

This is because only the latest version of nose is available through standard setuptools. There are no links on the website pointing to a previous version. In my case, I had run the install when the requirement was nose >= 0.8 so now I have the new version with no visible way to downgrade and the HEAD can not install because of this. So when I run tg-admin now, I get this:

leonexis@weathertop:~/workspace/turbogears$ tg-admin
Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 5, in ?
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.4/site-packages/setuptools-0.6a8-py2.4.egg/pkg_resources.py", line 2192, in ?
    working_set.require(__requires__)
  File "/usr/lib/python2.4/site-packages/setuptools-0.6a8-py2.4.egg/pkg_resources.py", line 503, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.4/site-packages/setuptools-0.6a8-py2.4.egg/pkg_resources.py", line 483, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: nose<0.8

I am forced to change the setup.py file in order for it to work (I do not plan on doing TurboGears tests as I am just trying to keep my development synchronized with the latest TurboGears 0.9 development).

Change History

comment:1 Changed 12 years ago by godoy

Hmmm... I believe this was fixed. Can you retry and close this bug if it works for you?

comment:2 Changed 11 years ago by elvelind

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.