Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2119 (closed enhancement: fixed)

Opened 10 years ago

Last modified 10 years ago

Warn Windows user to run exactly *python* initializeDB.py, not just initializeDB.py

Reported by: Artem Owned by: mark ramm
Priority: high Milestone: 2.0b2
Component: Documentation Version: 2.0b*
Severity: minor Keywords:
Cc:

Description

Even if you activate your virtualenv correctly if you ask Windows to run file.py it might use a different copy of python (not even in the path) and with a different set of libraries in the path. Small mistake, but difficult for figuring out (since just running python shell and checking the modules will show that everything is OK).

Wiki20 tutorial  http://turbogears.org/2.0/docs/main/Wiki20/wiki20.html should explicitly warn Windows users not to skip the *python* part of the command line. More details about the situation, consequences and how difficult it is to realize the root reason can be found at  http://groups.google.com/group/turbogears/browse_thread/thread/11757a2818f7546d

Setting high priority since it is related to the installation/quickstart procedure - point, when smooth user experience is very important.

Change History

comment:1 Changed 10 years ago by faide

I disagree. We should remove completely the doc about this method. The only true and clear method is to use:

paster setup-app development.ini

which is fully integrated and involves less coding... I have created a ticket to document properly this method already.

comment:2 Changed 10 years ago by faide

  • Version changed from 1.0.8 to 2.0b1

comment:3 Changed 10 years ago by mramm

  • Status changed from new to closed
  • Resolution set to fixed

Warning added to docs in rev #6002

Note: See TracTickets for help on using tickets.